Some errors occurred while installing PyTorch

I want to use Pytorch in brainframe,so I installed pytorch into the aotuai/brainframe_core:0.28.3 container locally.But some errors occurred.Can anyone give me some advice?

Hi! This is a good question- I’m not sure what’s going on in your picture, but here’s a quick tutorial for modifying the python libraries inside of the BrainFrame image. I hope this is helpful for you!

Instructions for Building

  1. First, download the following Dockerfile and cd into the same directory.
    Dockerfile (132 Bytes)

  2. Set an environment variable for the brainframe version you are targeting:

    export BRAINFRAME_VERSION=0.28.3
  3. In the same directory as the Dockerfile, run the build using the following command:

    docker build \
        --build-arg PYTHON_LIBRARIES=torch \
        --tag aotuai/brainframe_core:$BRAINFRAME_VERSION \

To change what libraries you want to install, just modify the PYTHON_LIBRARIES variable in the docker build command above.

You can then test to make sure the new image worked by running:

docker run -it aotuai/brainframe_core:0.28.3 python3 -c "import torch;print(torch.__version__)"

which will return the current installed version of pytorch inside of the container.

Thanks,Alex!I installed PyTorch as you suggested, but there were still some errors. Can you give me some advice?

It looks like you have a typo in your package name. I think the package your want is “torch”.

Thank you!It was an embarrassing mistake.I still get errors after I modify it.d509042f677ebd8a7d9c3fe63652ad7|336x500

I have successfully installed PyTorch on the server. There may just be some minor problems with the virtual machine installation. Thank you anyway.