Questions about Capsule button

Quick questions,
–Why is the capsule button not showing the enable button?
–Adding another camera is not working say the input is from the webcam.

Two things,

I have the downloaded option and I use sudo bash to open it, which opens up the software…
But the terminal keep showing the error (BrainFrameClient:78436): GdkPixbuf-CRITICAL **: 19:09:42.923: gdk_pixbuf_get_width: assertion ‘GDK_IS_PIXBUF (pixbuf)’ failed

When I used the snap option,

and within the terminal when I tried brainframe-client

it returns

File “/snap/brainframe-client/135/usr/local/lib/python3.6/site-packages/”, line 3, in
from brainframe_qt.util import preimport_hooks
File “/snap/brainframe-client/135/usr/local/lib/python3.6/site-packages/brainframe_qt/util/”, line 9, in
from gstly import gi_select_versions
ModuleNotFoundError: No module named ‘gstly’

Kindly assist.

Each capsule in the BrainFrame system encapsulates a deep neural network and has specific input and output requirements. These requirements are described in the capsule downloading table available at:

If the input of a capsule in the table is empty, such as the ‘Detector Face Openvino’ capsule, it means that the capsule doesn’t require any input other than the video frames.

On the other hand, the ‘Classifier Mas Closeup Openvino’ capsule has an input requirement of ‘Type: Single Detection, Detections: Face’, which means it needs the input of a face detection. In this case, you should use a capsule that produces the output ‘Detection: Face’, such as the ‘Detector Face Openvino’ Capsule. To make it work, load both the ‘Detector Face Openvino’ capsule and the ‘Classifier Mas Closeup Openvino’ capsule.

By following these instructions and loading the necessary capsules, you can ensure the proper functioning of the BrainFrame system.

Thanks for the feedback. The Error message might be due to inconsistent GDK version. If the Graphics User Interface works fine, then you can ignore the error messages.

The latest snap release is missing a library, please use the version you can download directly from the page under ‘For Ubuntu 18.04: Download’

We are continuously improving the user experience, hopefully the next release will address these issues.

Thank you.
Yes, I tried loading various inputs and outputs during the test…
It was working.