Failed to install vcap library on Ubuntu 18.04.4?

installation of vcap and vcap_utils failed on my Ubuntu machine, the error message is:
Could not find a version that satisfies the requirement tensorflow-gpu==1.15.2 (from vcap) (from versions: 0.12.1, 1.0.0, 1.0.1, 1.1.0, 1.2.0, 1.2.1, 1.3.0, 1.4.0, 1.4.1, 1.5.0, 1.5.1, 1.6.0, 1.7.0, 1.7.1, 1.8.0, 1.9.0, 1.10.0, 1.10.1, 1.11.0, 1.12.0, 1.12.2, 1.12.3, 1.13.1, 1.13.2, 1.14.0, 2.0.0a0, 2.0.0b0, 2.0.0b1)
No matching distribution found for tensorflow-gpu==1.15.2 (from vcap)

could anyone help me to fix it?

Hi tianguang, welcome to the forum!

This error usually means that you’re using an unsupported version of Python. Right now, vcap and vcap-utils only support up to Python 3.6, because that’s the highest version that Tensorflow 1.x supports.

In order to install Python 3.6 on Ubuntu 20.04, I would recommend using the deadsnakes PPA.

sudo add-apt-repository ppa:deadsnakes/ppa
sudo apt update
sudo apt install python3.6

Then, you can create a virtualenv that uses this Python executable. If you’re using virtualenvwrapper, you would do it like this:

mkvirtualenv -p /usr/bin/python3.6 capsule_dev

Then, you should be able to install vcap and vcap-utils without issue. Let me know how it goes for you!